Uploaded image for project: 'Kopano Groupware Core'
  1. Kopano Groupware Core
  2. KC-709

php-mapi: research problems with retrieving html from emails and resolving recipients

    XMLWordPrintable

    Details

    • Type: Research
    • Status: Closed
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 8.4.0, 8.4.0beta1, 8.4.0RC1
    • Component/s: None
    • Security Level: Public
    • Labels:
      None
    • Environment:
      Introduced around core 8.4.0~667

      Description

      https://forum.kopano.io/topic/296/bugreport-kc-8-4-0-667_139-error-while-accessing-html-mail-items-in-webapp

      "could not open message" for html mails reported on:
      CentOS 6.9
      PHP-FPM 5.6.30
      Core 8.4.0~667
      Webapp 3.4.0.676 or 3.4.0.670
      rolling back to core-8.4.0~644_137 restored functionality

      Ubuntu 14_04
      KopanoCore 8.4.0.669
      Webapp 3.3.0.610-25.1 or Webapp 3.4.0.676

      Ubuntu 16.04
      Core 8.4.0-728
      WebApp 3.4.0.686-479.1
      php-fpm (PHP 7.0)
      (z-push shows user himself as sender)

      https://forum.kopano.io/topic/321/incident-no-sender-on-iphones-since-latest-kopano-update

      no sender information synced to z-push reported on:
      Ubuntu 16.04.2 LTS
      Apache 2.4.18
      Z-Push 2.3.6
      Kopano 8.4.0-728
      was running 8.4.0-553 before

      https://forum.kopano.io/topic/315/kopano-core-8-4-0-sender-problems-after-upgrade
      some e-mails show no sender at all as well as on WebApp and on mobile devices (iOS
      Some mails won’t open on WebApp (failed to open Dialog)
      and I can not use the reply-to feature in any mail (empty recipient when editting mail)
      upon upgrade from 8.3.0~667 to 8.4.0~728

      https://forum.kopano.io/topic/328/send-as-not-work
      send-as not working
      when using send-as the dagent responds with a message that the user or group does not exist
      used 8.4.0-693 and afterwards downgraded to 8.4.0-35 (as stated in https://forum.kopano.io/topic/327/kopano-core-rollback)

      https://forum.kopano.io/topic/325/e-mail-answer-to-field-empty
      to field empty on email answer
      same user as "send-as not working"
      Core 8.4.0~728_144.1 and Webapp 3.4.0.686_479

      https://forum.kopano.io/topic/301/error-could-not-resolve-user
      Error Could not resolve user.
      Debian 7 x64
      WebApp: 3.4.0.676-474.1
      Kopano Core: 8.4.0-667
      says that dropping the database and reimporting with kopano-backup resolved the issue (https://forum.kopano.io/topic/301/error-could-not-resolve-user/4) (but also installed an older version)

      not affected:
      core-8.4.0~644_137
      8.4.0-553
      8.4.0-465
      8.4.0-415
      8.4.0-35
      8*.3.*0~667

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              fbartels Felix Bartels
            • Votes:
              3 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: